KEINOS' Blog

Official blog of KEINOS but mostly for my own reference. A Japanese made in Mexico with Mexican quality. Who monkey around the jungle of codes. ;-)


Project maintained by KEINOS Hosted on GitHub Pages — Theme by mattgraham

INDEX


macOS CheetSheet

This is a memorandum for KEINOS.

Get OS version info

$ sw_vers
ProductName:    Mac OS X
ProductVersion: 10.15.7
BuildVersion:   19H1615

How to check current DNS server using

scutil --dns | grep 'nameserver\[[0-9]*\]'

How to boot from external drive

How to check macOS Recovery Partition

$ # View partition
$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS 名称未設定               499.2 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

/dev/disk1 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *15.5 GB    disk1
   1:                       0xEF                         2.1 MB     disk1s2

Disalbe CSR Utils

$ csrutil disable
...

Homebrew

Run as a service

brew services start <name>
$ brew services start ipfs
...

How to create key pari for SSH and sign

mkdir -p ~/.ssh
chmod 0755 ~/.ssh
ssh-keygen -t ed25519 -C "your mail"